暫時解決無法安裝程式的問題

Nexus One、Desire 用戶有沒有發覺自從升級至 Android 2.2 後,經常出現程式安裝或更新失敗的問題?其實歸根究底是 Android 2.2 的 Apps2SD 功能存在很嚴重的 bug,以致支援 Apps2SD 的程式無法安裝,Google 已經承認此問題。現在大家除了等待更新釋出之外,也可以嘗試以下的方法暫時解決問題,步驟如下:

  1. 刪除 SD 中的 android_secure/smdl2tmp1.asec 文件,由於該檔案是暫時性,所以刪除也不會影響系統運作。
  2. 再到 Android Market 重新下載並安裝程式
  3. 如果以上方法都不成功,請先掛載 SD 卡才好下載並安裝程式

關鍵字: , , , , ,

Both comments and pings are currently closed.

9 thoughts on “暫時解決無法安裝程式的問題

  1. nice…岩岩就係煩緊呢個問題…
    仲以為自己架n1有事…

    Thumb up 0 Thumb down 0

  2. 咦? 係咪部部都有呢個問題呢?
    我同朋友2部 desire 都up 左去 2.2 接近一個月…
    但係好似無installation 呢個問題喎..

    Thumb up 0 Thumb down 0

  3. 我都係用緊desire 2.2既,本身都冇咩事,但係呢篇文出左之後冇耐就裝唔到野,之後就長期顯示下載中-.-

    Thumb up 0 Thumb down 0

    • 長期顯示下載中
      應該係唔夠storage裝app
      你留意下

      Thumb up 0 Thumb down 0

  4. 我將部電話D storage整返多D之後就可以DL到野喇~
    真係唔該晒!!
    不過好多時都話更新失敗又真既~

    Thumb up 0 Thumb down 0

  5. android_secure/smdl2tmp1.asec 下搵唔到呢個 file
    而家一直更新唔到

    Thumb up 0 Thumb down 0

  6. 如果用呢個command “pm setInstallLocation 2 “改過APP TO SD 要還完先可以安裝MARKET下載既檔案。

    如果要更新只要將D APP轉返入手機就可以更新或下載。

    Thumb up 1 Thumb down 0